Retrieves the GUID representing this element in DWF and IFC export.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static Guid GetExportId( Document document, ElementId elementId ) |
Visual Basic |
---|
Public Shared Function GetExportId ( _ document As Document, _ elementId As ElementId _ ) As Guid |
Visual C++ |
---|
public: static Guid GetExportId( Document^ document, ElementId^ elementId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
The id of the element.
Return Value
The value of the GUID representing the element in the export context.
Remarks
This id is used in the contents of DWF export and IFC export and it should be used
only when cross-referencing to the contents of these export formats.
When storing Ids that will need to be mapped back to elements in future sessions,
UniqueId must be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |