Add elements into the system and connect them with the system using given connectors.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual void Add( ConnectorSet connectors ) |
Visual Basic |
---|
Public Overridable Sub Add ( _ connectors As ConnectorSet _ ) |
Visual C++ |
---|
public: virtual void Add( ConnectorSet^ connectors ) |
Parameters
- connectors
- Type: Autodesk.Revit.DB..::..ConnectorSet
Connectors which are used to connect with the system.
Remarks
Note: this method may not be called during dynamic update.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connectors is nullNothingnullptra null reference (Nothing in Visual Basic), or any connector in that collection is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the operation failed. |
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update. |