The vertical length of the notch profile from the top.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double NotchThickness { get; set; } |
Visual Basic |
---|
Public Property NotchThickness As Double Get Set |
Visual C++ |
---|
public: property double NotchThickness { double get (); void set (double value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for notchThickness must be between 0 and 30000 feet. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set. |