Represents the possible outcomes of a request for raising an external event.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum ExternalEventRequest |
Visual Basic |
---|
Public Enumeration ExternalEventRequest |
Visual C++ |
---|
public enum class ExternalEventRequest |
Members
Member name | Description |
---|---|
Accepted | Request accepted; event was added into the event queue and will be executed momentarily. |
Pending | Request not accepted, because the previous request is still pending (not executed). |
Denied | Request was denied due to failures of the corresponding event handler. |
TimedOut | Request not accepted due to synchronization issues with other thread(s). |