Removes component repeaters from the document,
but leaves the individual repeated components in their respective locations and
hosted on their original hosts.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015 Subscription Update
Syntax
C# |
---|
public static ISet<ElementId> RemoveRepeaters( Document document, ISet<ElementId> elementIds ) |
Visual Basic |
---|
Public Shared Function RemoveRepeaters ( _ document As Document, _ elementIds As ISet(Of ElementId) _ ) As ISet(Of ElementId) |
Visual C++ |
---|
public: static ISet<ElementId^>^ RemoveRepeaters( Document^ document, ISet<ElementId^>^ elementIds ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document that contains the component repeaters to remove.
- elementIds
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The set of component repeaters that should be removed.
Return Value
A collection of components that were previously repeated by the component repeater.
Remarks
In addition to the component repeaters the component repeater slots
are also removed from the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in elementIds do not exist in the document. -or- Not all given elements are component repeaters. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |