Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public FamilyInstanceCreationData(
	XYZ location,
	FamilySymbol symbol,
	StructuralType structuralType
)
Visual Basic
Public Sub New ( _
	location As XYZ, _
	symbol As FamilySymbol, _
	structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
	XYZ^ location, 
	FamilySymbol^ symbol, 
	StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
Specify if the family instance is structural.

See Also