Assign a new list of constraints to this vertex.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetConstraints( IList<RebarShapeConstraint> constraints ) |
Visual Basic |
---|
Public Sub SetConstraints ( _ constraints As IList(Of RebarShapeConstraint) _ ) |
Visual C++ |
---|
public: void SetConstraints( IList<RebarShapeConstraint^>^ constraints ) |
Parameters
- constraints
- Type: System.Collections.Generic..::..IList<(Of <(<'RebarShapeConstraint>)>)>
A new list of constraints.
Remarks
Any existing constraints are discarded. The new constraints replace them.
Any parameters driving the constraints must already be added
with RebarShapeDefinition.AddParameter().
The allowable constraint types are:
- RebarShapeConstraintRadius
- RebarShapeConstraintArcLength
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | One or more of the constraints is of a type not supported for RebarShapeVertex. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |