An interface to be executed when an external event is raised.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public interface IExternalEventHandler |
Visual Basic |
---|
Public Interface IExternalEventHandler |
Visual C++ |
---|
public interface class IExternalEventHandler |
Remarks
An instance of a class implementing this interface will be registered
with Revit first, and every time the corresponding external event
is raised, the Execute method of this interface will be invoked.