Checks whether a bar exists at the specified position.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool DoesBarExistAtPosition( int barPosition ) |
Visual Basic |
---|
Public Function DoesBarExistAtPosition ( _ barPosition As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool DoesBarExistAtPosition( int barPosition ) |
Parameters
- barPosition
- Type: System..::..Int32
A bar position index between 0 and NumberOfBarPositions-1.
Remarks
Returns true, unless the bar position is the first or last
in the set and it is suppressed by IncludeFirstBar or
IncludeLastBar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barPosition is not in the range [ 0, NumberOfBarPositions-1 ]. |