Gets the Element object (either Host or Rebar) which provides the constraint. Will return the Element which contains the face at targetIndex.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018

Syntax

C#
public Element GetTargetElement(
	int targetIndex
)
Visual Basic
Public Function GetTargetElement ( _
	targetIndex As Integer _
) As Element
Visual C++
public:
Element^ GetTargetElement(
	int targetIndex
)

Parameters

targetIndex
Type: System..::..Int32
The index of the target. Should be between 0 and NumberOfTargets().

Return Value

Returns the Element object (either Host or Rebar) which provides the constraint. Will return the Element which contains the face at targetIndex.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException targetIndex is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException RebarConstraint is no longer valid.

See Also