Creates a new AppearanceAssetElement from an existing rendering asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static AppearanceAssetElement Create( Document document, string name, Asset asset ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ name As String, _ asset As Asset _ ) As AppearanceAssetElement |
Visual C++ |
---|
public: static AppearanceAssetElement^ Create( Document^ document, String^ name, Asset^ asset ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which to create the AppearanceAssetElement.
- name
- Type: System..::..String
The name of the AppearanceAssetElement.
- asset
- Type: Autodesk.Revit.DB.Visual..::..Asset
The rendering asset of the element.
Return Value
The new AppearanceAssetElement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name cannot include prohibited characters. -or- The given value for name is already in use as an appearance asset name. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |