Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static bool ValidatePoint( Point GPoint ) |
Visual Basic |
---|
Public Shared Function ValidatePoint ( _ GPoint As Point _ ) As Boolean |
Visual C++ |
---|
public: static bool ValidatePoint( Point^ GPoint ) |
Parameters
- GPoint
- Type: Autodesk.Revit.DB..::..Point
Point object to be validated.
Return Value
True is %GPoint% is acceptable as a part of a wireframe shape representation being built.
Remarks
This function may be used to pre-validate the geometry being added to avoid an exception from AddPoint().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |