The measurement type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public PointOnCurveMeasurementType MeasurementType { get; set; } |
Visual Basic |
---|
Public Property MeasurementType As PointOnCurveMeasurementType Get Set |
Visual C++ |
---|
public: property PointOnCurveMeasurementType MeasurementType { PointOnCurveMeasurementType get (); void set (PointOnCurveMeasurementType value); } |
Remarks
The measurement type is not checked until this class is assigned for a particular reference point on a particular curve.
At that time, the measurement type must be valid for the curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |