Type of geometry primitive represented as a number.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public enum PrimitiveType |
Visual Basic |
---|
Public Enumeration PrimitiveType |
Visual C++ |
---|
public enum class PrimitiveType |
Members
Member name | Description |
---|---|
TriangleList | Geometry consisting of a list of triangles. |
LineList | Geometry consisting of a list of line segments. |
PointList | Geometry consisting of a list of points. |