Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public SchedulableField(
	ScheduleFieldType fieldType
)
Visual Basic
Public Sub New ( _
	fieldType As ScheduleFieldType _
)
Visual C++
public:
SchedulableField(
	ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException fieldType is not a schedulable field type
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also