Set the length of the rod's top extension into structure. The rod must be attached to structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public bool SetRodStructureExtension(
int rodIndex,
double extension
) |
Visual Basic |
---|
Public Function SetRodStructureExtension ( _
rodIndex As Integer, _
extension As Double _
) As Boolean |
Visual C++ |
---|
public:
bool SetRodStructureExtension(
int rodIndex,
double extension
) |
Parameters
- rodIndex
- Type: System..::..Int32
The rod index.
- extension
- Type: System..::..Double
Distance the rod will extend into the structure.
Return Value
returns true if it worked.
Exceptions
See Also