The number of potential bars in the set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2009
Syntax
C# |
---|
public int NumberOfBarPositions { get; set; } |
Visual Basic |
---|
Public Property NumberOfBarPositions As Integer Get Set |
Visual C++ |
---|
public: property int NumberOfBarPositions { int get (); void set (int value); } |
Remarks
The number of positions is equal to the number of actual
bars (the Quantity), plus one or two more positions depending
on IncludeFistBar and IncludeLastBar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the number of bar positions numberOfBarPositions is less than 1 or more than 1002. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: This rebar element represents a single bar (the layout rule is Single). |