Flag indicating whether the asset describes a material that is thermally treated or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public bool MetalThermallyTreated { get; set; } |
Visual Basic |
---|
Public Property MetalThermallyTreated As Boolean Get Set |
Visual C++ |
---|
public: property bool MetalThermallyTreated { bool get (); void set (bool value); } |
Remarks
Applies to Metal-based structural assets.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal to set this property. |