Checks if the given connector is a valid piping connector.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static bool IsPipingConnector( Connector connector ) |
Visual Basic |
---|
Public Shared Function IsPipingConnector ( _ connector As Connector _ ) As Boolean |
Visual C++ |
---|
public: static bool IsPipingConnector( Connector^ connector ) |
Parameters
- connector
- Type: Autodesk.Revit.DB..::..Connector
Connector to check
Return Value
True if the connector has the Piping domain type.
Remarks
A connector must be Piping domain type to be connected with other pipes.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |