Retrieves the electrical systems that are currently created using this MEPModel.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public ISet<ElectricalSystem> GetElectricalSystems() |
Visual Basic |
---|
Public Function GetElectricalSystems As ISet(Of ElectricalSystem) |
Visual C++ |
---|
public: ISet<ElectricalSystem^>^ GetElectricalSystems() |
Remarks
This property returns a set of Electrical Systems. If there are no electrical systems created
for this model, this property will be an empty set.
This method supersedes an older ElectricalSystems property which has been deprecated.