The diameter of the MEP curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double Diameter { get; } |
Visual Basic |
---|
Public ReadOnly Property Diameter As Double Get |
Visual C++ |
---|
public: property double Diameter { double get (); } |
Remarks
This property is used to retrieve the diameter of the MEP curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the MEP curve's Shape is not round. |