Interface class for external servers implementing Pipe plumbing fixture flow calculation.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public interface IPipePlumbingFixtureFlowServer : IExternalServer |
Visual Basic |
---|
Public Interface IPipePlumbingFixtureFlowServer _ Inherits IExternalServer |
Visual C++ |
---|
public interface class IPipePlumbingFixtureFlowServer : IExternalServer |
Remarks
A typical way to use the external server can be:
- Implement a server class that derives from this interface
- Create a new server object and register it with the service, see ExternalServiceRegistry.
- Assign server for the plumbing flow conversion in PipeSettings.