Set the level for a View Depth plane
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetLevelId( PlanViewPlane planViewPlane, ElementId id ) |
Visual Basic |
---|
Public Sub SetLevelId ( _ planViewPlane As PlanViewPlane, _ id As ElementId _ ) |
Visual C++ |
---|
public: void SetLevelId( PlanViewPlane planViewPlane, ElementId^ id ) |
Parameters
- planViewPlane
- Type: Autodesk.Revit.DB..::..PlanViewPlane
The View Depth plane
- id
- Type: Autodesk.Revit.DB..::..ElementId
Id of the level
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |