An enumerated type indicates the circuit path mode
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public enum ElectricalCircuitPathMode |
Visual Basic |
---|
Public Enumeration ElectricalCircuitPathMode |
Visual C++ |
---|
public enum class ElectricalCircuitPathMode |
Members
Member name | Description |
---|---|
Custom | The circuit path is customized by user. |
FarthestDevice | The circuit path connects to the farthest devices. |
AllDevices | The circuit path connects to all the devices in the circuits, this mode is compatible to the legacy behavior. |