A copy of the ExportFontInfo for the font's ExportFontKey.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ExportFontInfo this[ ExportFontKey fontKey ] { get; set; } |
Visual Basic |
---|
Public Default Property Item ( _ fontKey As ExportFontKey _ ) As ExportFontInfo Get Set |
Visual C++ |
---|
public: virtual property ExportFontInfo^ default[ExportFontKey^ fontKey] { ExportFontInfo^ get (ExportFontKey^ fontKey) sealed; void set (ExportFontKey^ fontKey, ExportFontInfo^ value) sealed; } |
Parameters
- fontKey
- Type: Autodesk.Revit.DB..::..ExportFontKey
Return Value
A copy of the ExportFontInfo.
Remarks
When getting this property, it returns a copy of the ExportFontInfo from the table. In order to
make changes to the ExportFontInfo and use those settings during export, set the modified
ExportFontInfo back into the table using the same key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table. |