Sets graphic overrides for a category in view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetCategoryOverrides( ElementId categoryId, OverrideGraphicSettings overrideGraphicSettings ) |
Visual Basic |
---|
Public Sub SetCategoryOverrides ( _ categoryId As ElementId, _ overrideGraphicSettings As OverrideGraphicSettings _ ) |
Visual C++ |
---|
public: void SetCategoryOverrides( ElementId^ categoryId, OverrideGraphicSettings^ overrideGraphicSettings ) |
Parameters
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
Category to be overridden
- overrideGraphicSettings
- Type: Autodesk.Revit.DB..::..OverrideGraphicSettings
Object representing all graphic overrides of the category categoryId in view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Category cannot be overridden. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. |