Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetOrientation( ViewOrientation3D newViewOrientation3D ) |
Visual Basic |
---|
Public Sub SetOrientation ( _ newViewOrientation3D As ViewOrientation3D _ ) |
Visual C++ |
---|
public: void SetOrientation( ViewOrientation3D^ newViewOrientation3D ) |
Parameters
- newViewOrientation3D
- Type: Autodesk.Revit.DB..::..ViewOrientation3D
The new orientation to set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is locked and cannot be reoriented. |