Converts a group of ModelCurves to equivalent SymbolicCurves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created.
The lines are projected on the view workplane.
The view workplane must be parallel to the view plane.
If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses.
Splines are modified.
- modelCurves
- Type: Autodesk.Revit.DB..::..ModelCurveArray
The model curve array to be converted.
Remarks
Exceptions
Exception | Condition |
---|
System..::..ArgumentNullException |
Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
|
System..::..ArgumentException |
Thrown when view is invalid to create SymbolicCurves on it.
|
System..::..InvalidOperationException |
Thrown when current document is a family.
Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.
|
See Also