Gets graphic overrides for a category in view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public OverrideGraphicSettings GetCategoryOverrides( ElementId categoryId ) |
Visual Basic |
---|
Public Function GetCategoryOverrides ( _ categoryId As ElementId _ ) As OverrideGraphicSettings |
Visual C++ |
---|
public: OverrideGraphicSettings^ GetCategoryOverrides( ElementId^ categoryId ) |
Parameters
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
Category to be checked.
Return Value
Object representing all graphic overrides of the category categoryId in view. A default OverrideGraphicSettings object will be returned if it not previously been set for this view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. |