Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public ISet<ElementId> GetPropagationViews( View view ) |
Visual Basic |
---|
Public Function GetPropagationViews ( _ view As View _ ) As ISet(Of ElementId) |
Visual C++ |
---|
public: ISet<ElementId^>^ GetPropagationViews( View^ view ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.
Return Value
A set of ElementIds of the parallel views for extent propagation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |