Presets for given Analytical Projection Z.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum SurfaceElementProjectionZ |
Visual Basic |
---|
Public Enumeration SurfaceElementProjectionZ |
Visual C++ |
---|
public enum class SurfaceElementProjectionZ |
Members
Member name | Description |
---|---|
TopOrInterior | Top for floor or Interior Face for wall element. |
CenterOfElement | Center of element. |
BottomOrExterior | Bottom for floor or Exterior Face for wall element. |
CenterOfCore | Center of core. Applicable for wall analytical model only. |
Plane | Use a Plane for projection (e.g., Grid, Level). |