Checks that if there is a solid-solid cut between two elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public static bool CutExistsBetweenElements(
Element first,
Element second,
out bool firstCutsSecond
) |
Visual Basic |
---|
Public Shared Function CutExistsBetweenElements ( _
first As Element, _
second As Element, _
<OutAttribute> ByRef firstCutsSecond As Boolean _
) As Boolean |
Visual C++ |
---|
public:
static bool CutExistsBetweenElements(
Element^ first,
Element^ second,
[OutAttribute] bool% firstCutsSecond
) |
Parameters
- first
- Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid.
- second
- Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid.
- firstCutsSecond
- Type: System..::..Boolean%
If the return value of this function is true, this indicates which element is the cutting element from the pair.
True if the first solid cuts the second one, false if the second solid cuts the first one.
Return Value
True if there is a solid-solid cut between the input elements, false otherwise.
Exceptions
See Also