Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static void AddCutBetweenSolids( Document document, Element solidToBeCut, Element cuttingSolid, bool splitFacesOfCuttingSolid ) |
Visual Basic |
---|
Public Shared Sub AddCutBetweenSolids ( _ document As Document, _ solidToBeCut As Element, _ cuttingSolid As Element, _ splitFacesOfCuttingSolid As Boolean _ ) |
Visual C++ |
---|
public: static void AddCutBetweenSolids( Document^ document, Element^ solidToBeCut, Element^ cuttingSolid, bool splitFacesOfCuttingSolid ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
- solidToBeCut
- Type: Autodesk.Revit.DB..::..Element
The solid to be cut.
- cuttingSolid
- Type: Autodesk.Revit.DB..::..Element
The cutting solid.
- splitFacesOfCuttingSolid
- Type: System..::..Boolean
True to split faces of cutting solid where it intersects the solid to be cut, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to add solid-solid cut for the two elements. |