Checks if the server referenced by the given ExternalResourceReference supports the
ExternalResourceReferenceType of this KeyBasedTreeEntryTable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool ServerSupports( ExternalResourceReference extRef ) |
Visual Basic |
---|
Public Function ServerSupports ( _ extRef As ExternalResourceReference _ ) As Boolean |
Visual C++ |
---|
public: bool ServerSupports( ExternalResourceReference^ extRef ) |
Parameters
- extRef
- Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to check.
Return Value
True if the ExternalResourceReference refers to a server that supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. False otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |