This enumeration corresponds to the surfaceType attribute in gbXML
and identifies the type of surface defined.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public enum gbXMLSurfaceType |
Visual Basic |
---|
Public Enumeration gbXMLSurfaceType |
Visual C++ |
---|
public enum class gbXMLSurfaceType |
Members
Member name | Description |
---|---|
InteriorWall | Interior wall. |
ExteriorWall | Exterior wall. |
Roof | Roof. |
InteriorFloor | Interior floor. |
Shade | Shade. |
UndergroundWall | Underground wall. |
UndergroundSlab | Underground slab. |
Ceiling | Ceiling. |
SurfaceAir | Surface air. |
UndergroundCeiling | Underground ceiling. |
RaisedFloor | Raised floor. |
SlabOnGrade | Slab on grade. |
NoOfSurfaceTypes | No of surface types. |