Used for the conceptual energy model.
The approximate percentage of the building roof surfaces in
massing instances for the Conceptual Energy Analytical Model.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public double PercentageSkylights { get; set; } |
Visual Basic |
---|
Public Property PercentageSkylights As Double Get Set |
Visual C++ |
---|
public: property double PercentageSkylights { double get (); void set (double value); } |
Remarks
This value is used to automatically model the skylights in
massing instances when the Energy Analytical model is being created.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage skylights value is between 0.00 and 0.95. |