Returns an individual repeating reference given by coordinates in the array, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public Reference GetReference( RepeaterCoordinates coordinates ) |
Visual Basic |
---|
Public Function GetReference ( _ coordinates As RepeaterCoordinates _ ) As Reference |
Visual C++ |
---|
public: Reference^ GetReference( RepeaterCoordinates^ coordinates ) |
Parameters
- coordinates
- Type: Autodesk.Revit.DB..::..RepeaterCoordinates
The coordinates in the array of repeating references.
Return Value
The repeating reference.
Remarks
The coordinates must be within the bounds of the repeating reference source.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates are not valid for the repeating reference source. This could be because of a mismatched dimensionality or because the coordinates are outside the bounds of the repeating reference source. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The repeating reference source is no longer valid. |