Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void RotateSubElement(
Reference subElementReference,
Line axis,
double angle
) |
Visual Basic |
---|
Public Sub RotateSubElement ( _
subElementReference As Reference, _
axis As Line, _
angle As Double _
) |
Visual C++ |
---|
public:
void RotateSubElement(
Reference^ subElementReference,
Line^ axis,
double angle
) |
Parameters
- subElementReference
- Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex
- axis
- Type: Autodesk.Revit.DB..::..Line
An unbounded line that represents the axis of rotation.
- angle
- Type: System..::..Double
The angle, in radians, by which the element is to be rotated around the specified axis.
See Also