Sets the wall's end not to join to other walls.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void DisallowWallJoinAtEnd( Wall wall, int end ) |
Visual Basic |
---|
Public Shared Sub DisallowWallJoinAtEnd ( _ wall As Wall, _ end As Integer _ ) |
Visual C++ |
---|
public: static void DisallowWallJoinAtEnd( Wall^ wall, int end ) |
Parameters
- wall
- Type: Autodesk.Revit.DB..::..Wall
The wall in question
- end
- Type: System..::..Int32
0 or 1 for the beginning or end of the wall's curve
Remarks
If this wall is already joined at this end, it will become disconnected.
If this wall is a stacked wall, all subwalls at this end will be disallowed to join.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |