Represents a curve loop based profile for sweep or swept blend elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class CurveLoopsProfile : SweepProfile |
Visual Basic |
---|
Public Class CurveLoopsProfile _ Inherits SweepProfile |
Visual C++ |
---|
public ref class CurveLoopsProfile : public SweepProfile |
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory
to create the profile.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..CurveLoopsProfile
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..CurveLoopsProfile