Sets the ElementIds for Category elements which are ignored by route calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2020

Syntax

C#
public void SetIgnoredCategoryIds(
	ICollection<ElementId> categoryIds
)
Visual Basic
Public Sub SetIgnoredCategoryIds ( _
	categoryIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetIgnoredCategoryIds(
	ICollection<ElementId^>^ categoryIds
)

Parameters

categoryIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The ids of Categories to be ignored by route calculation.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One or more ElementIds in categoryIds are not valid Category element ids.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also