Determines whether the current rendering pass is for transparent objects.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static bool IsTransparentPass() |
Visual Basic |
---|
Public Shared Function IsTransparentPass As Boolean |
Visual C++ |
---|
public: static bool IsTransparentPass() |
Return Value
True when the server should be submitting transparent objects for rendering, false otherwise.
Remarks
Opaque and transparent geometry should be submitted for rendering separately. See UseInTransparentPass(View).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |