Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public virtual Bitmap GetPreviewImage(
Size size
) |
Visual Basic |
---|
Public Overridable Function GetPreviewImage ( _
size As Size _
) As Bitmap |
Visual C++ |
---|
public:
virtual Bitmap^ GetPreviewImage(
Size size
) |
Parameters
- size
- Type: System.Drawing..::..Size
The width and height of the preview image in pixels.
Return Value
System::Drawing::Bitmap represents the preview image.
nullNothingnullptra null reference (Nothing in Visual Basic) if there is no preview image.
Exceptions
See Also