The top extension plane ID option.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public ElementId TopExtensionPlaneId { get; set; }
Visual Basic
Public Property TopExtensionPlaneId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ TopExtensionPlaneId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

This Plane identifies a Level, a Grid, or a Ref Plane. To validate plane use [!:Autodesk::Revit::DB::Structure::AnalyticalModelColumn::isPlaneValidForExtension] method.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL

See Also