Checks for errors or inconsistencies in the data in this CompoundStructure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function IsValid ( _
doc As Document, _
<OutAttribute> ByRef errMap As IDictionary(Of Integer, CompoundStructureError), _
<OutAttribute> ByRef twoLayerErrorsMap As IDictionary(Of Integer, Integer) _
) As Boolean |
Visual C++ |
---|
public:
bool IsValid(
Document^ doc,
[OutAttribute] IDictionary<int, CompoundStructureError>^% errMap,
[OutAttribute] IDictionary<int, int>^% twoLayerErrorsMap
) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
Access to the document in which the CompoundStructure will be used.
- errMap
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'Int32, CompoundStructureError>)>)>%
This map will associate each problematic layer index to a value in CompoundStructureError.
General structure errors are reported as associated to layer index -1.
- twoLayerErrorsMap
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'Int32, Int32>)>)>%
The map is associated to a check run only for vertically Compound Structures.
Essentially the Compound Structure is sliced at representative heights.
It looks at the region from exterior to interior, and requires that the assigned layer indices do not decrease.
If they do, an entry is generated for this map. The first entry is the last valid layer index encountered.
The second entry is a region id whose assigned layer index is too small: it should be at least as large as the first entry.
Return Value
True if the compound structure is valid for the document, false otherwise.
Remarks
Exceptions
See Also