Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public ElementIsCurveDrivenFilter( bool inverted ) |
Visual Basic |
---|
Public Sub New ( _ inverted As Boolean _ ) |
Visual C++ |
---|
public: ElementIsCurveDrivenFilter( bool inverted ) |
Parameters
- inverted
- Type: System..::..Boolean
True if the filter should match all elements which are not curve driven elements.
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve.
Example elements found by this filter include walls, beams, and curve elements.