Constructs a new instance of a filter to match walls that have the given structural wall usage.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public StructuralWallUsageFilter( StructuralWallUsage structuralWallUsage ) |
Visual Basic |
---|
Public Sub New ( _ structuralWallUsage As StructuralWallUsage _ ) |
Visual C++ |
---|
public: StructuralWallUsageFilter( StructuralWallUsage structuralWallUsage ) |
Parameters
- structuralWallUsage
- Type: Autodesk.Revit.DB.Structure..::..StructuralWallUsage
The wall structural usage.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |