Gets a Field of a given name from the Schema.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public Field GetField( string name ) |
Visual Basic |
---|
Public Function GetField ( _ name As String _ ) As Field |
Visual C++ |
---|
public: Field^ GetField( String^ name ) |
Parameters
- name
- Type: System..::..String
The Field name
Return Value
The Field
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Reading of Entities of this Schema is not allowed to the current add-in. |