Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<ElementId> GetAllRevisionIds() |
Visual Basic |
---|
Public Function GetAllRevisionIds As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetAllRevisionIds() |
Return Value
The ordered array of ids of Revisions participating in the sheet's revision schedules.
Remarks
The Revisions are ordered according to the revision sequence in the project.
A Revision is considered to be participating in revision scheduling on the sheet
if either a revision cloud belonging to that Revision is visible on the sheet or the Revision
has been explicitly included using the Revisions On Sheet parameter.