Creates a new instance of a demand factor definition.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static ElectricalDemandFactorDefinition Create( Document ADoc, string strName ) |
Visual Basic |
---|
Public Shared Function Create ( _ ADoc As Document, _ strName As String _ ) As ElectricalDemandFactorDefinition |
Visual C++ |
---|
public: static ElectricalDemandFactorDefinition^ Create( Document^ ADoc, String^ strName ) |
Parameters
- ADoc
- Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
- strName
- Type: System..::..String
The name of the electrical demand factor definition to be created.
Return Value
The newly created demand factor definition element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |